Back to overview
Degraded

ENS responses not being received

Apr 7, 2026 at 12:08pm UTC
Affected services
Safety & Security (ENS)

Resolved
Apr 7, 2026 at 9:57pm UTC

The issue has been largely resolved

Created
Apr 7, 2026 at 12:08pm UTC

GB Safety & Security submissions are not receiving responses from HMRC.