Back to overview
Resolved

Some ICS2 declarations are not receiving Risk Assessments

Jul 13, 2026 at 2:34pm UTC
Affected services
ICS2

Resolved
Jul 14, 2026 at 8:45am UTC

Most ICS2 declarations are now receiving Risk Assessments within the normal timeframe

Created
Jul 13, 2026 at 2:34pm UTC

ICS2 declarations are not currently receiving Risk assessments, and some are taking longer than expected to be submitted to EU customs.