Back to overview
Resolved

ICS2 is currently down

Jun 25, 2026 at 9:16am UTC
Affected services
ICS2

Resolved
Jun 28, 2026 at 8:36am UTC

ICS2 MRNs and Risk Assessments are being returned within normal timescales

Updated
Jun 26, 2026 at 8:09am UTC

The EU ICS2 systems are currently down, and the EU have implemented the Business Continuity Procedure

Created
Jun 25, 2026 at 9:16am UTC

The ICS2 system is currently down. This is an ICS2 system issue and we reported it to the authorities.