Back to overview
Resolved

Some ICS2 declarations taking longer than expected to be accepted

May 29, 2026 at 2:50pm UTC
Affected services
ICS2

Resolved
May 29, 2026 at 9:18pm UTC

ICS2 declarations are now returning MRNs. If your declaration is still waiting in the "Submitted" state please submit a new declaration.

Created
May 29, 2026 at 2:50pm UTC

We have detected that a small number of ICS2 declarations are not being accepted by EU customs in a timely manner