Back to overview
Resolved
ICS2 declarations not receiving responses
May 20, 2026 at 11:04am UTC
Affected services
ICS2
Resolved
May 21, 2026 at 7:53am UTC
ICS2 declarations are receiving responses but some risk assessments are delayed
Affected services
Created
May 20, 2026 at 11:04am UTC
ICS2 declarations are not receiving MRNs. This is an ICS2 system issue and it has been reported to EU Customs.
Affected services