Back to overview
Resolved

ICS2 declarations not receiving responses

May 15, 2026 at 10:04am UTC
Affected services
ICS2

Resolved
May 16, 2026 at 3:56pm UTC

ICS2 MRNs are being returned within normal response times

Updated
May 16, 2026 at 8:27am UTC

ICS2 declarations are still having processing problems. This is causing delays in MRNs being generated.

Updated
May 15, 2026 at 9:16pm UTC

ICS2 MRNs are now being returned within normal timescales. Some declarations have received an MRN but are still in the Rejected state. We have tried to resolve the affected declarations but please contact us if your ICS2 declaration appears in the wrong state.

Updated
May 15, 2026 at 4:07pm UTC

Most ICS2 messages are failing due to a serious technical problem with EU customs systems.

Updated
May 15, 2026 at 12:50pm UTC

ICS2 declarations are not receiving MRNs due to a connection problem with EU customs. We are awaiting further updates.

Created
May 15, 2026 at 10:04am UTC

We are noticing problems submitting ICS2 declarations to EU customs. We are investigating this.