Back to overview
Resolved
ELO declarations are receiving delayed responses
Apr 28, 2026 at 3:43pm UTC
Affected services
ELO
Resolved
Apr 28, 2026 at 8:25pm UTC
ELO responses from FR Customs have returned to normal.
Affected services
Updated
Apr 28, 2026 at 5:49pm UTC
ELO declarations are receiving responses but they are being delayed by up to 90 minutes
Affected services
Created
Apr 28, 2026 at 3:43pm UTC
We are detecting some ELO declarations are not receiving responses.
Affected services