Back to overview
Resolved
ICS2 declarations not receiving responses
Apr 24, 2026 at 10:26am UTC
Affected services
ICS2
Resolved
Apr 24, 2026 at 5:52pm UTC
ICS2 MRNs are being returned successfully
Affected services
Updated
Apr 24, 2026 at 2:27pm UTC
ICS2 declarations are still not receiving responses from EU customs
Affected services
Created
Apr 24, 2026 at 10:26am UTC
We have detected ICS2 declarations are not receiving MRNs from the EU system. We are monitoring this situation.
Affected services