Back to overview
Resolved

ICS2 declarations not receiving responses

May 22, 2026 at 1:16pm UTC
Affected services
ICS2

Resolved
May 22, 2026 at 2:14pm UTC

ICS2 declarations are behaving as expected

Created
May 22, 2026 at 1:16pm UTC

We are currently monitoring ICS2 declarations that are not receiving MRNs.