Back to overview
Resolved
Some ICS2 declarations being rejected
May 18, 2026 at 10:58am UTC
Affected services
ICS2
Resolved
May 18, 2026 at 6:03pm UTC
ICS2 MRNs are being returned as normal
Affected services
Created
May 18, 2026 at 10:58am UTC
We are seeing that a small number of ICS2 declarations are being rejected.
Affected services