Back to overview
Resolved

ICS2 declarations not receiving responses

May 13, 2026 at 10:35am UTC
Affected services
ICS2

Resolved
May 13, 2026 at 6:34pm UTC

ICS declarations are receiving normal responses.

Updated
May 13, 2026 at 3:01pm UTC

ICS2 MRNs are starting to be returned for some entries with severe delays.

Created
May 13, 2026 at 10:35am UTC

ICS2 is currently having system issues which the customs authorities are aware of.