Back to overview
Resolved
ICS2 declarations are encountering intermittent failures
Apr 30, 2026 at 8:25am UTC
Affected services
ICS2
Resolved
Apr 30, 2026 at 12:41pm UTC
ICS2 MRNs are now being returned at a normal rate, and risk assessments are being completed.
Affected services
Updated
Apr 30, 2026 at 10:07am UTC
ICS2 MRNs are being returned at the normal rates, but some declarations do not have risk assessment. Some valid EORIs are not being accepted.
Affected services
Created
Apr 30, 2026 at 8:25am UTC
We have detected that a number of ICS2 declarations are encountering technical issues from the EU systems. We are monitoring this.
Affected services