Back to overview
Resolved
ELO declarations are not being accepted by FR customs
Apr 22, 2026 at 9:18am UTC
Affected services
ELO
Resolved
Apr 22, 2026 at 10:59am UTC
ELO declarations are now being processed
Affected services
Created
Apr 22, 2026 at 9:18am UTC
We have detected that ELO declarations are not being accepted. We are monitoring this situation.
Affected services