Back to overview
Resolved
ICS2 declarations not receiving responses
Apr 22, 2026 at 9:05am UTC
Affected services
ICS2
Resolved
Apr 22, 2026 at 8:09pm UTC
ICS2 is now working normally
Affected services
Updated
Apr 22, 2026 at 11:59am UTC
ICS2 MRNs are again delayed
Affected services
Updated
Apr 22, 2026 at 9:58am UTC
Risk assessments are starting to be completed, but still delayed.
Affected services
Updated
Apr 22, 2026 at 9:46am UTC
Some ICS2 MRNs are being generated but delays are 30-60 minutes. Risk assessments are not being completed.
Affected services
Created
Apr 22, 2026 at 9:05am UTC
We are monitoring ICS2 because some submissions are not receiving responses.
Affected services