Back to overview
Resolved

ICS2 declarations not receiving responses

Apr 9, 2026 at 10:43am UTC
Affected services
ICS2

Resolved
Apr 14, 2026 at 9:01pm UTC

ICS2 MRNs are being generated and risk assessments are being returned within a normal length of time

Updated
Apr 14, 2026 at 6:31am UTC

ICS2 MRNs are being generated within a normal timeframe, however Risk Assessments are still suffering significantly delays.

Updated
Apr 13, 2026 at 9:15pm UTC

ICS2 declarations are receiving MRNs but the process is delayed by 3-4 hours. Risk assessments are not being completed so these MRNs cannot be used on ELO.

Updated
Apr 13, 2026 at 11:20am UTC

ICS2 Business Continuity Plan (BCP) has been activated by the EU TAXUD Service Desk

Updated
Apr 13, 2026 at 7:49am UTC

ICS2 declarations are still receiving significantly delayed responses.

Updated
Apr 12, 2026 at 8:48am UTC

Some ICS2 declarations are receiving responses up to 24 hours after submission

Updated
Apr 11, 2026 at 6:56pm UTC

Some ICS2 declarations are receiving responses approximately 18 hours after submission

Updated
Apr 10, 2026 at 4:02pm UTC

ICS2 declarations are not receiving responses from EU customs.

Updated
Apr 10, 2026 at 12:37pm UTC

ICS2 declarations are still taking hours to receive a response from EU customs

Updated
Apr 10, 2026 at 8:43am UTC

ICS2 responses are coming through slowly

Updated
Apr 9, 2026 at 1:53pm UTC

ICS2 declarations are not receiving responses from EU customs.

Updated
Apr 9, 2026 at 11:01am UTC

We are starting to see some ICS2 declarations being accepted and MRNs generated. We will continue to monitor.

Created
Apr 9, 2026 at 10:43am UTC

We are investigating an issue affecting all ICS2 declarations, where the response is not being received from EU customs.