Back to overview
Resolved
Intermittent ICS2 failures
Aug 21, 2026 at 7:37pm UTC
Affected services
ICS2
Resolved
Aug 22, 2026 at 11:14am UTC
ICS2 declarations are receiving the expected responses
Affected services
Created
Aug 21, 2026 at 7:37pm UTC
We have detected some ICS2 declarations are not being accepted by EU customs.
Affected services