Back to overview
Resolved

ICS2 declarations are encountering intermittent failures

Aug 10, 2026 at 5:36pm UTC
Affected services
ICS2

Resolved
Aug 10, 2026 at 7:54pm UTC

ICS2 declarations are now being submitted successfully

Created
Aug 10, 2026 at 5:36pm UTC

We have detected that some ICS2 declarations are not being accepted by EU customs. We are investigating this.